AWS outage impacting Mapbox core services

Incident Report for Mapbox

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 00:40 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 21, 2025 - 00:12 UTC

Monitoring

We are monitoring the recovery of Mapbox services and data pipelines after the cloud provider outage.
Posted Oct 20, 2025 - 23:55 UTC

Identified

We have received reports from AWS that multiple core services are experiencing instability. This is currently impacting multiple Mapbox services with degraded performance and errors.
While AWS systems are currently recovering, we are working on restoring health of impacted Mapbox services.
Posted Oct 20, 2025 - 10:59 UTC
This incident affected: Navigation (API), Maps (API), and Data Services (Telemetry, Mapbox Traffic Data).