Unable to verify email address
Incident Report for Mapbox
Resolved
This incident has been resolved.
Posted Jun 23, 2020 - 19:40 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 23, 2020 - 19:33 UTC
Identified
We have identified an issue that's preventing users from being able to verify their email address as part of account creation. We're releasing a fix shortly.
Posted Jun 23, 2020 - 19:20 UTC
This incident affected: Accounts.