Services Status

Increased Searchbox latency for eu-west-1 P95

Incident Report for Mapbox

Resolved

After last correction latency is back to normal. Incident report will be shared soon.
Posted 1 month ago. May 14, 2025 - 08:39 UTC

Update

Another correction/Hot fix was applied to reduce the load.
Posted 1 month ago. May 14, 2025 - 05:51 UTC

Monitoring

Latency Anomaly mitigation is in-place. Latency is back to normal.
Posted 1 month ago. May 14, 2025 - 02:28 UTC

Identified

Bottleneck has been identified. We are increasing the capacity of the Search Box system
Posted 1 month ago. May 14, 2025 - 00:54 UTC

Investigating

We are currently investigating this issue.
Posted 1 month ago. May 13, 2025 - 23:59 UTC
This incident affected: Search.