Elevated Latency
Incident Report for Mapbox
Resolved
We have confirmed with our upstream provider that on September 9, 2020 between 13:34 EDT and 13:48 EDT and also a few hours before that (exact time frame is not accounted yet), clients may have experienced elevated errors and latency when connecting to edge locations in North America. The issue has been resolved and the service is operating normally.
Posted Sep 09, 2020 - 19:29 UTC
Identified
Update: We've identified that the increased latency is due to an issue with an upstream edge provider. We are working with the upstream provider to help isolate the cause and work towards resolution.
Posted Sep 09, 2020 - 19:21 UTC
Investigating
We're experiencing an elevated level of latency for the Search API and are currently looking into the issue.
Posted Sep 09, 2020 - 19:02 UTC
This incident affected: Navigation (API) and Search.