Statistics page data delays
Incident Report for Mapbox
Resolved
The incident has been resolved and all the missing usage data has been backfilled.
Posted Dec 16, 2020 - 06:36 UTC
Update
Missing usage data for 12/12, 12/13 and 12/14 is still being slowly backfilled and aggregated. We expect the process to take a few more hours, today.
Posted Dec 15, 2020 - 17:23 UTC
Monitoring
We started backfilling the missing data. It will take a few hours before we're all caught up, but individual Account Statistics pages should now begin to reflect the missing stats, gradually, as our pipelines complete processing batches of data.
We expect to be done by early morning Pacific Time tomorrow, 12/15.
Posted Dec 14, 2020 - 22:26 UTC
Identified
The Account Statistics page is currently showing partial usage data starting 12/12/2020 due to an internal data ingestion and transformation issue, affecting graphs and reports for API requests and User Sessions.
The cause has been identified and a fix has been implemented. We will soon start computing all the missing usage data and backfill the data sets.
Posted Dec 14, 2020 - 19:55 UTC
This incident affected: Accounts.