Mapbox Traffic Data delivery delays
Incident Report for Mapbox
Resolved
This incident has been resolved.
Posted Jun 24, 2022 - 20:54 UTC
Investigating
Typical traffic data is experiencing delivery delays.
Posted Jun 21, 2022 - 15:14 UTC
This incident affected: Data Services (Mapbox Traffic Data).