Incorrect Satellite Tiles
Incident Report for Mapbox
Resolved
We have identified and resolved the issue.
Posted 8 months ago. Jan 08, 2019 - 12:03 UTC
Investigating
We are investigating reports of our Tiles API returning incorrect tiles for some satellite maps.
Posted 8 months ago. Jan 08, 2019 - 03:56 UTC
This incident affected: Maps (API).