Degraded ETA and Traffic Visualization

Incident Report for Mapbox

Resolved

This incident has been resolved.
Posted Jul 15, 2025 - 06:01 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 15, 2025 - 04:54 UTC

Investigating

Mapbox navigation products are experiencing degraded ETAs and Traffic visualization. We are investigating the issue.
Posted Jul 14, 2025 - 19:30 UTC
This incident affected: Navigation (API) and Data Services (Mapbox Traffic Data, Traffic Congestion Visual Layer).