Static Images API degradation
Incident Report for Mapbox
Postmortem

The issue with 3D Terrain distortion has been mitigated and fixes have been shipped to all Static Image and Tile endpoints.

Posted May 22, 2024 - 15:03 UTC

Resolved
We have identified the root cause of this issue and have a clear path forward, but expect the rollout to take some time. We are closing this status but will post updates as fixes are available.
Posted May 17, 2024 - 19:58 UTC
Identified
We have identified the cause of the image degradation. However, given the nature of the issue, we do not anticipate a fix to be rolled out imminently. We will provide more updates on timeline as we have them.
Posted May 17, 2024 - 15:33 UTC
Update
We are still investigating image quality degradation on the Static Images API
Posted May 17, 2024 - 15:17 UTC
Update
This issue impacts Static API requests for styles using the mapbox.mapbox-terrain-dem-v1 tileset. Not all requests are impacted and the issue is sporadic. We are continuing to investigate the cause of the issue.
Posted May 17, 2024 - 01:14 UTC
Investigating
We are investigating image quality degradation on the Static Images API
Posted May 17, 2024 - 00:04 UTC
This incident affected: Maps (API).