Delayed emails
Incident Report for Mapbox
Resolved
This incident has been resolved. Emails are now being sent in a timely manner.
Posted Jun 17, 2020 - 23:03 UTC
Monitoring
Contrary to the initial update, we believe this incident is affecting all types of emails from Mapbox, not just verification emails. We have received word from our email vendor that the root cause has been resolved, and we are now waiting for a backlog of data to clear out before the timing of emails returns to normal.
Posted Jun 17, 2020 - 22:10 UTC
Investigating
We are currently looking into reports that our email verification emails are taking a long time to arrive.
Posted Jun 17, 2020 - 18:54 UTC
This incident affected: Accounts.