Increased error rates on the Account Dashboard
Incident Report for Mapbox
Resolved
We are seeing full recovery of our systems. This incident is resolved.
Posted May 11, 2020 - 17:25 UTC
Monitoring
We have identified an issue with our upstream payment processor, which affected various actions across the dashboard, including sign ups. We are already seeing recovery and are actively monitoring.
Posted May 11, 2020 - 17:05 UTC
This incident affected: Accounts.