Services Status

Directions/Map Matching APIs ETA Accuracy

Incident Report for Mapbox

Postmortem

On May 10 between 3:00 a.m. and 11:00 a.m. UTC, some Mapbox customers experienced longer than normal travel times in some geographical areas.

The following services may have been affected during that period: Directions API, Map Matching API, Navigation SDK and Mapbox Dash.

As of 11:00 a.m. UTC on May 10, the issue was remediated and all services were functioning normally. Our root cause analysis revealed an issue with a data pipeline that impacted our routing engine’s ability to accurately compute travel time for a given route in some geographical areas.

We have put safeguards in place to address the issue. We apologize for any inconvenience this may have caused you or your customers. If you have any questions, please contact Support or your Mapbox account manager.

Posted 3 years ago. May 13, 2022 - 23:01 UTC

Resolved

This incident has been resolved.
Posted 3 years ago. May 10, 2022 - 12:31 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 3 years ago. May 10, 2022 - 11:16 UTC

Identified

We are currently experiencing an issue with our Directions and Map Matching APIs where our ETAs are inaccurate. We have identified the issue and are working on a fix.
Posted 3 years ago. May 10, 2022 - 10:23 UTC
This incident affected: Navigation (API, Mobile SDK).