Signup form entry issues
Incident Report for Mapbox
Resolved
The problematic component has been fixed and signups are now operational. Deployment of the fix was delayed by instability in CI and deployment systems that have been resolved.
Posted over 1 year ago. Dec 17, 2015 - 00:58 UTC
Identified
We have identified an issue preventing certain users from entering data into our signup form.
Posted over 1 year ago. Dec 16, 2015 - 20:35 UTC